App Stuck in the Oven but working Locally?

Hello!

I created an uploaded an app and it seems to be stuck in the oven!


Here is a photo of it as of now.

The link is https://share.streamlit.io/crodriguezm2016/spotifywrapped/main/spotifyapp.py

My Github Repo is GitHub - crodriguezm2016/SpotifyWrapped

I’m not too sure why it isn’t working on the site though. When I run it locally, it works fine…

The category “Using streamlit” is mainly for bug fixes. Show the community is presenting your finished work.

Maybe try creating an automatic requirements.txt file with…

pip freeze > requirements.txt

…within the folder of your project locally. So cd into your folder locally, then execute the command. Then use the generated requirements.txt file and switch it with your current one and try it again.

1 Like

Hi @crodriguezm2016 -

Given that your requirements.txt file has over 140 entries, you might be running into a situation where pip can’t quickly resolve the exact environment you are specifying.

Something to test would be to only specify the packages you are directly importing into your app, and leaving the rest of the dependencies to resolve to whatever package pip thinks is appropriate. You can automatically generate that file using pipreqs.

Best,
Randy

Hey @randyzwitch I initially only had a few in there but then tried Max’s suggestion which is how I got the 140 lol. I used pipreqs to generate the file and still seem to have my app stuck in the oven so I am not sure what the issue is now.

I just made a fork and the app launched, so now I don’t know what to suggest :frowning:

Maybe delete the app and re-launch it? There’s nothing wrong with your Python project structure as far as I can tell.

Deleting and relaunching fixed it! Thanks!