Bizarre problem: can't install regex over requirements

As it says on the title… I tried searching everywhere but in general the consensus is that you shouldn’t even need to install regex at all, but removing it from the requirements file or specifying versions didn’t work. This is the error message:

ERROR: Could not find a version that satisfies the requirement re (from versions: none)
ERROR: No matching distribution found for re

The app deploys fine locally. This is what I’m getting from my attempt to deploy it on the cloud. I really only have one single function that requires regex (to correct postal code formatting) so in theory I could remove it and just make the app slightly less functional, but this is really strange?

This is what is in my current requirements file:

streamlit
streamlit_authenticator
st_pages
numpy
pandas
geopandas
geopy
folium
streamlit_folium

re is installed with Python and doesn’t need to be in your requirements file. I would expect an error message if re is included in your requirements file. Since you’ve said you’ve tried removing it, can you do the following to confirm:

  1. Share a link to your repository (if possible)
  2. Have your requirements file saved as above (without re).
  3. Reboot your app.
  4. Share the complete logs from that fresh reboot up to the error.