Chatsonic library

I’m trying to build an app with chatsonic package, but I have error in requirements, it seems it doesn’t installed in the cloud.

Hi @TowardsInnovationLab,

Can you share with us the error message that you’re getting, which will be helpful in troubleshooting the problem.

Best regards,
Chanin

Yes surely!!!
Thanks


Here the message in the Manage App:

Collecting streamlit

Downloading streamlit-1.21.0-py2.py3-none-any.whl (9.7 MB)

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 9.7/9.7 MB 96.0 MB/s eta 0:00:00[2023-04-16 04:29:07.462238]

Collecting requests

Downloading requests-2.28.2-py3-none-any.whl (62 kB)

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 62.8/62.8 KB 154.5 MB/s eta 0:00:00[2023-04-16 04:29:07.581055]

ERROR: Could not find a version that satisfies the requirement chatsonic==0.1.2 (from versions: none)

ERROR: No matching distribution found for chatsonic==0.1.2

WARNING: You are using pip version 22.0.3; however, version 23.1 is available.

You should consider upgrading via the '/home/appuser/venv/bin/python -m pip install --upgrade pip' command.

Checking if Streamlit is installed

────────────────────────────────────────────────────────────────────────────────────────

[04:29:08]`` ❗️ installer returned a non-zero exit code

[04:29:08]`` ❗️ Error during processing dependencies! Please fix the error and push an update, or try restarting the app.

[04:30:43]`` ❗️ Streamlit server consistently failed status checks

[04:30:43]`` ❗️ Please fix the errors, push an update to the git repo, or reboot the app.

Hi,

In the requirements.txt file, instead of chatsonic can you use chatsonic-py instead.

According to Pypi

done but I have the same mistake.
I’ll try another solution

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.