ERROR: Could not find a version that satisfies the requirement pywin32==301 (from versions: none)

ERROR: Could not find a version that satisfies the requirement pywin32==301 (from versions: none)
ERROR: No matching distribution found for pywin32==301
WARNING: You are using pip version 21.1.1; however, version 21.1.3 is available.
You should consider upgrading via the '/home/appuser/venv/bin/python -m pip install --upgrade pip' command.

My app can not be deployed. Below is my app link:

I already upgrade below in PyCharm terminal:
(venv) C:\Users\zoujo\Documents\PyCharm>py -m pip install --upgrade pip
Requirement already satisfied: pip in c:\users\zoujo\documents\pycharm\venv\lib\site-packages (21.1.3)

(venv) C:\Users\zoujo\Documents\PyCharm>py -m pip install pywin32==301
Requirement already satisfied: pywin32==301 in c:\users\zoujo\documents\pycharm\venv\lib\site-packages (301)

Please help on it. Thank you!

Hi @zoujojo, welcome to the Streamlit community!! :wave: :partying_face:

The pywin32 module provides access to many of the Windows APIs from Python. Apps deployed to Streamlit Sharing are executed in a Linux environment. As such, pywin32 fails to install on non-Windows systems, including Streamlit Sharing.

To fix the error, remove both pywin32 and pywinpty from lines 72 and 73 of your requirements.txt file.

Make sure to upload any datasets (including California_Fire_Incidents.csv) used in your app to the GitHub repo.

Happy Streamlit’ing! :balloon:
Snehan