Error Installing ETNA library

  1. link to the public deployed app - https://hotel-demand-prediction-bi.streamlit.app/
  2. link to your app’s public GitHub repository - GitHub - ZakharovNerd/hotel-demand-prediction

including a [requirements file] - https://github.com/ZakharovNerd/hotel-demand-prediction/blob/main/requirements.txt
3. Share the full text of the error message (not a screenshot).

So the problem is that I want to create an app that installs etna library, but I can not install it.

I have already tried to add “etna”, “etna-ts” to the requirements.txt, tried to downgrade the python version within streamlit app from 3.11 to 3.8, then I tried to install this package using pip: “pip install etna”, “pip install etna-ts”. But it never solved the issue . The error text is:

ModuleNotFoundError: No module named ‘etna’

Traceback:

File "/home/vscode/.local/lib/python3.11/site-packages/streamlit/runtime/scriptrunner/script_runner.py", line 534, in _run_script
    exec(code, module.__dict__)File "/workspaces/hotel-demand-forecast/Hello.py", line 17, in <module>
    from etna.datasets import TSDataset
  1. Share the Streamlit and Python versions.

I have tried 3.11, and then tried 3.8

Try etna instead of etna-ts, use python version 3.10 on streamlit cloud and do a reboot of your streamlit app.

Is there any bugs creating new cloud streamlit with python < 3.11?

I created somewhat 10 different apps with needed python version using this interface:

Sometimes it gives different errors like this one:

or this one:

And other ones about permissions.

But when the app is created and I check the python version with

python3 --version

It gives python 3.11 version

Am I missing something when choosing the needed python version?