ERROR: Installing requirements

When I try to install “rocketcea” library, I get this error log:

Rocket-Nozzle_Sizing/Rocket_Nozzle_Sizing_streamlit/logs-gitmechub-rocket-nozzle_sizing-test-Rocket_Nozzle_Sizing_streamlit-1_Home.py-2024-03-31T06_17_10.935Z.txt at main · GitMechub/Rocket-Nozzle_Sizing · GitHub

I was able to install the other libraries in the requirements file without including rocketcea, and I did not encounter any errors. Here’s the link to my requirements file:

Rocket_Nozzle_Sizing_streamlit

Link to the app: Streamlit (rocket-nozzlesizing-z2rxf4j6rsxaeygsozafgc.streamlit.app)

1 Like

Try this, create a file packages.txt, on this file write gfortran.

packages.txt

gfortran

Save that in the same location as your requirements.txt.

1 Like

Thank you for your reply

I tried this but the same error is still showing up

1 Like

Does this work when run locally or on your pc?

2 Likes

Move it to the root folder of the github repo and do a reboot afterwards.

3 Likes

Thank you, guys!

This worked.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.