Error trying to call streamlit hello

Dear community,

I’ve just installed streamlit and tried to call ‘streamlit hello’, however I get the following error:

(base) C:>streamlit hello Traceback (most recent call last): File “c:\users\s158539\appdata\local\continuum\anaconda3\lib\”, line 193, in run_module_as_main “main”, mod_spec) File “c:\users\s158539\appdata\local\continuum\anaconda3\lib\”, line 85, in run_code exec(code, run_globals) File "C:\Users\s158539\AppData\Local\Continuum\anaconda3\Scripts\", line 5, in File "c:\users\s158539\appdata\local\continuum\anaconda3\lib\site-packages\", line 121, in from streamlit.DeltaGenerator import DeltaGenerator as _DeltaGenerator File “c:\users\s158539\appdata\local\continuum\anaconda3\lib\site-packages\streamlit\”, line 33, in from streamlit import caching File “c:\users\s158539\appdata\local\continuum\anaconda3\lib\site-packages\streamlit\”, line 38, in from streamlit.hashing import CodeHasher File “c:\users\s158539\appdata\local\continuum\anaconda3\lib\site-packages\streamlit\”, line 36, in from streamlit.folder_black_list import FolderBlackList File “c:\users\s158539\appdata\local\continuum\anaconda3\lib\site-packages\streamlit\”, line 39, in if config.get_option(“global.developmentMode”): File “c:\users\s158539\appdata\local\continuum\anaconda3\lib\site-packages\streamlit\”, line 94, in get_option parse_config_file() File “c:\users\s158539\appdata\local\continuum\anaconda3\lib\site-packages\streamlit\”, line 877, in parse_config_file _update_config_with_toml(file_contents, filename) File “c:\users\s158539\appdata\local\continuum\anaconda3\lib\site-packages\streamlit\”, line 799, in _update_config_with_toml parsed_config_file = toml.loads(raw_toml) File “c:\users\s158539\appdata\local\continuum**\anaconda3\lib\site-packages\toml\”, line 379, in loads original, pos) toml.decoder.TomlDecodeError: Key group not on a line by itself. (line 1 column 1 char 0)**

Can anyone help me to solve this error?

Thank you all in advance!

1 Like

Hi @Jepetto,

Welcome to the forum :wave:

Looks like your issue has been resolved via the discussion at Toml docoder error?

Did you manually create your config.toml file?

Was the contents of your file the exact same as is mentioned in the discussion at the link above?

1 Like

Yes, the thread you are referring too solved my problem in the end :slight_smile:

1 Like