Module not found error holoviews

Hello everybody!

My project used to work, but when showing it to a friend the other day I now get this error:

ModuleNotFoundError: No module named ‘holoviews’

It used to work just fine, but I went ahead and explicitly added holoviews to my requirements.txt file. Unfortunately I’m still getting the same error after committing my changes.

Here is a link to my repo:

Can anyone help?

Garrett

Hi @Garrett :wave:

It looks like you’ve deleted your app on Community Cloud. When I forked you repo and deployed, here’s what the logs say:

INFO: pip is looking at multiple versions of <Python from Requires-Python> to determine which version is compatible with other requirements. This could take a while.

INFO: pip is looking at multiple versions of pandas to determine which version is compatible with other requirements. This could take a while.

ERROR: Cannot install -r /app/realestate_of_mind/requirements.txt (line 2) and holoviews==1.0.0 because these package versions have conflicting dependencies.

The conflict is caused by:

    The user requested holoviews==1.0.0

    hvplot 0.7.3 depends on holoviews>=1.11.0

To fix this you could try to:

1. loosen the range of package versions you've specified
2. remove package versions to allow pip attempt to solve the dependency conflict

ERROR: ResolutionImpossible: for help visit https://pip.pypa.io/en/latest/topics/dependency-resolution/#dealing-with-dependency-conflicts
WARNING: You are using pip version 22.0.3; however, version 22.2.2 is available.
You should consider upgrading via the '/home/appuser/venv/bin/python -m pip install --upgrade pip' command.
Checking if Streamlit is installed
────────────────────────────────────────────────────────────────────────────────────────
[05:10:43] ❗️ installer returned a non-zero exit code
[05:10:43] ❗️ Error during processing dependencies! Please fix the error and push an update, or try restarting the app.
[05:12:23] ❗️ Streamlit server consistently failed status checks
[05:12:23] ❗️ Please fix the errors, push an update to the git repo, or reboot the app.

The solution is to upgrade your hvplot and holoviews packages to non-obsolete, compatible versions. Replace the contents of your requirements.txt with the following:

pandas==1.4.2
hvplot==0.8.1
nasdaq-data-link==1.0.2
pandas_ta==0.3.14b0
matplotlib==3.5.1
holoviews==1.15.0
streamlit==1.12.2

Once you make the above changes, you will not loner run into the ModuleNotFoundError when deploying your app.

Hey there! I made your changes to my requirements file and rebooted the app, but I’m still getting the same error.

Here’s a link to the app.

https://forte42-realestate-of-mind-streamlit-app-3-create-projec-4pbiyv.streamlitapp.com/

You should try deleting your app and redeploying it. Let me know if that doesn’t help. :balloon:

Thank you! I also had to put pydeck in the requirements. I appreciate your help.