"ModuleNotFoundError" but the module is correctly installed

I get this error:

File "/app/trial-aid/streamlit_app.py", line 2, in <module>
    import plotly.express as px

However plotly is correctly installed through conda env .yml file (version=5.5.0), moreover before I pushed to the repository and updated the app it was perfectly working (and I didn’t change the plotly import).

The repository can be found at: https://github.com/voidpunk/Trial-AId

I also tried to delete and re-build the app, but it keeps the environment and only reboot it, which isn’t really helpful…

Hi @voidpunk -

Did you figure this out? I typed in amoxicillin like your example and it seems to work now.

Best,
Randy

Yes, sorry, I forgot to post the solution.

It was only due to some sort of conflict between libraries, I deleted the environment and recreates a new one, then I reinstalled the needed libraries and exported the yml, it worked. I installed some libraries to get some data in the same environment which weren’t needed for the final app, I suspect that one of them may be the cause of the environment not working on deploying (on local, Streamlit app was still working perfectly even in the “broken” environment)