/tmp not writable is problematic

I am under the impression that /tmp is not writable in Streamlit Cloud (/var/tmp is). In principle applications should respect TMPDIR, but in practice some don’t: they fail obscurely, and debugging becomes very frustrating and time-consuming. (One such app is Libreoffice, but others have been mentioned in the forum).

Would it be possible to make /tmp writable (if necessary, via a bind mount or a tmpfs)?

Thanks

Welcome to the community @tonigi

I seem to remember from Discord that yes /tmp is not currently writable and @randyzwitch will suggest this to the engineering team.

What software are you trying to get installed with apt that fail the /tmp write if the dev team were to test changes?

Have a nice day,
Fanilo :balloon:

In my case, LibreOffice and unoconv (required to convert/generate PDFs). The error message, at conversion time, is very cryptic.

Yes, I’ve communicated this to our engineering team, but I do not know yet when any changes to /tmp permissions will get incorporated into Streamlit Cloud.

Thanks! That’s going to save headaches.

Hey @tonigi! Our engineers worked on a fix for this, which should be released over the next few days. Let me know if you’re still having trouble next week or so!

1 Like

Quick update: the fix should be released now but you might need to delete and recreate your app for now.

1 Like

Well, that worked :slight_smile: Thanks for the tool.

1 Like