301 for hosted Streamlit application with Redirect loop - AWS, EKS, and Istio reverse proxy

Hi there,

I’ve deployed a Stream-lit application on EKS in AWS with a containerised solution. I’m exposing it via API Gateway which is using a VPC Link and then proxies calls into my EKS Cluster. I have a toml file that looks like this:

toolbarMode = "auto"

[theme]
base="light"
primaryColor="#277A27"
secondaryBackgroundColor="#F8FAFA"
backgroundColor="#EAF1F2"
textColor="#11203E"
font="sans serif"

[server]
enableCORS = false
enableXsrfProtection = false
headless = true
baseUrlPath = "streamlit"

I am hosting it on a url, let’s say it’s [Redacted].api.myurl.com. When I access [Redacted].api.myurl.com/streamlit/healthz I get a 200 ‘ok’ response as I expect. However when I try and access the application under [Redacted].api.myurl.com/streamlit/ I end up in a huge redirect loop where it keeps attempting to load that same url. I have tried setting browser.serverAddress and a bunch of different configuration but I have no luck.

My EKS has a Gateway, VirtualService and Service but i’m assuming that’s all configured correctly along with my AWS components since I am able to hit the health check endpoint.

If any more information is needed to debug this, I can provide it. Any help here would be greatly appreciated!

Hi @Carlton_Sandhu

Would adding a forward slash preceding streamlit so that it becomes /streamlit help to resolve the issue?

More in this forum post: