App does not load. Just spins

When I try and open my cloud hosted stream lit app I just get a spinning circle. It never loads. Please help.

1 Like

Same issue here. My apps don’t work right now. There seems to be a wider issue.
Event doc pages not loading st.multiselect - Streamlit Docs

Maybe related to the outage yesterday…

1 Like

Same here.

Same, sounds like a streamlit issue.

Same here pls help :slight_smile:

Same issue.

my app suddenly stopped working also. Just signed up to streamlit. It worked for first hr then it keeps loading. Similar to others.

I tried to delete the app but won’t delete (i can go through the process but it just doesn’t delete).

Same Issue

Same here. I hope it resolves soon. For your information: https://www.streamlitstatus.com/

App is working again. The streamlit status indicates no outage. Can someone please explain what could of happened to avoid this in the future?

I’ve checked from a couple of apps that I’ve created and it seems that apps are running normally now. There was indeed a short downtime with the spinning circle. Will make note of this to our engineering team.