App has a problem with accessing code in my private GitHub repo

Hi,

I have an app hosted in Streamlit Cloud for nearly a year now. It worked just fine but a week or two ago stopped with this message:

[ UTC ] Logs for scalesense.streamlit.app/
────────────────────────────────────────────────────────────────────────────────────────
[07:12:21] :rocket: Starting up repository: ‘scalesense’, branch: ‘streamlit-demo’, main module: ‘streamlit_ui.py’
[07:12:21] :octopus: Cloning repository…
[07:12:25] :octopus: failed
[07:12:40] :octopus: failed
[07:12:54] :octopus: failed
[07:13:08] :octopus: failed
[07:13:22] :octopus: failed
[07:13:32] :octopus: Failed to download the sources for repository: ‘scalesense’, branch: ‘streamlit-demo’, main module: ‘streamlit_ui.py’
[07:13:32] :octopus: Make sure the repository and the branch exist and you have write access to it, and then reboot the app.
[07:15:12] :exclamation: Streamlit server consistently failed status checks
[07:15:12] :exclamation: Please fix the errors, push an update to the git repo, or reboot the app.

Clearly the problem is with GitHub private repo access. I’ve tried disconnecting my repo and adding access again, but the problem remains. Streamlit asks only for public repo access and there is no notification in Settings panel that allow me to grant private repo access. Could someone check what is going on and how can I get my app running again.

Regards,
Bohdan

Hey it’s better to launch the app again

Hi BLukash,

Maybe just try deploying an app from a template or forking the example repo and see if that works. Let’s hope so :slight_smile:

Hi! It looks like the deployment key used for your application is invalid. You should delete the application and deploy it again.

Deleting and deploying app didn’t helped. I received email on new public SSH key being generated for Streamlit from GitHub, but Streamlit still could not access my repository and no message in Settings to grant private repositories access. Can it be somehow related to the fact that I enabled 2FA on GitHub? The app itself is working, I can start it locally or via Codespaces, so the problem is in access that is 100%

Hi @BLukash

Could you try granting access between Streamlit and your GitHub account. There’s additional information here:

Hope this helps!