AttributeError: module 'matplotlib.cbook' has no attribute 'mplDeprecation'

Good day,
I was trying to use " streamlit_pandas_profiling" however, the same error message appears whatever the environment or matplotlib version.

(( AttributeError: module ‘matplotlib.cbook’ has no attribute ‘mplDeprecation’))

Need help from anybody who faced the same problem.

thank you.

Code snippet:

add code here

If applicable, please provide the steps we should take to reproduce the error or specified behavior.

Expected behavior:

Explain what you expect to happen when you run the code above.

Actual behavior:

Explain the undesired behavior or error you see when you run the code above.
If you’re seeing an error message, share the full contents of the error message here.

Debug info

  • Streamlit version: (get it with $ streamlit version)
  • Python version: (get it with $ python --version)
  • Using Conda? PipEnv? PyEnv? Pex?
  • OS version:
  • Browser version:

Requirements file

Using Conda? PipEnv? PyEnv? Pex? Share the contents of your requirements file here.
Not sure what a requirements file is? Check out this doc and add a requirements file to your app.


  • Link to your GitHub repo:
  • Link to your deployed app:

Additional information

If needed, add any other context about the problem here.

Hi @Ali_Sultan, and welcome to our community! :raised_hands:

It’s been a while since the streamlit_pandas_profiling library has been updated, so my assumption is that you may need to downgrade your matplotlib version to one compatible with the streamlit_pandas_profiling module.

You can try version 3.2.2 or another suitable version as follows:

pip install matplotlib==3.2.2

I hope this resolves the issue for you.

Let me know.


Yes I noticed that profiling library wasn’t updated in the last 2 years, let me try your solution hopefully can resolve that issue and thanks a lot for your response.

I also encountered the same error and I was able to resolve it by installing version 3.5.1. Thanks @Charly_Wargnier for the tip!

pip install matplotlib==3.5.1

Thanks all for your responses
It worked on matplotlib==3.7


Special thanks to @Charly_Wargnier

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.

Glad it helped @Ali_Sultan @ldaguidote! :hugs:

1 Like