BERT large model in Community plan

Hello

I would like to use a large version of a BERT model which has 1.33G. Is it possible to use it in the Community plan? I can run the application, but after some tests it fails: “This app has gone over its resource limits. I’ve tried a lot of caching config, but I can’t figure out how to solve it or if the reason is that it’s not possible to run a model with this size in the Community plan.

I’m going to share this app to get a feedback from users which I’ll use in a paper I’m writing about this NLP task. I would appreciate if you could help me. Thanks in advance :slight_smile:

My app: https://share.streamlit.io/lucianozanuz/streamlit-lener_br/main

1 Like

Hi @lucianozanuz

I believe this one to be too large, indeed.

However there are other smaller models that I’ve used in the past, delivering good results + running smoothly with the free Community plan.

Let me know how it goes with your test.

Best,
Charly

Thanks for the reply @Charly_Wargnier

Well, I’ve trained a BERT base model with slightly worse results and I’m using it for now. If it was possilble I would prefer to use the large version. But it seems it isn’t possible.

Thanks

Good to hear @lucianozanuz!

Feel free to share your app in the Show-the-community section! :balloon:

Best,
Charly