Can not install RDKit when deploy

When I deploy st_sdf_helper.py, I get the following errors:

Downloading pandas-1.1.0-cp37-cp37m-manylinux1_x86_64.whl (10.5 MB)
Collecting Pillow==8.2.0
Downloading Pillow-8.2.0-cp37-cp37m-manylinux1_x86_64.whl (3.0 MB)
ERROR: Could not find a version that satisfies the requirement rdkit==2020.03.2.0 (from versions: none)
ERROR: No matching distribution found for rdkit==2020.03.2.0

RDKit is not in PIP. I installed it locally from conda-forge:
conda create -c conda-forge rdkit

The requirements.txt is as below:
altair==4.1.0
streamlit==0.82.0
pandas==1.1.0
Pillow==8.2.0
rdkit==2020.03.2.0

Can anyone help? Thanks a ton!

@llzhu welcome to the community. Could You try with rdkit-pypi instead of rdkit in your requirements file?
Check this:

Regards

Thanks @napoles3d
It worked!

I am using Windows, so I could not install from rdkit-pypi locally. I simply changed requirements.txt. I tried several versions, one of them worked!

Thanks again.

2 Likes

Awesome! I have to try it
Regards!