Can't find dependencies torch==1.9.0+cu102

While I was trying to deploy a web app I was getting this error :

ERROR: Could not find a version that satisfies the requirement torch==1.9.0+cu102 (from versions: 0.1.2, 0.1.2.post1, 0.1.2.post2, 0.4.1, 0.4.1.post2, 1.0.0, 1.0.1, 1.0.1.post2, 1.1.0, 1.2.0, 1.3.0, 1.3.1, 1.4.0, 1.5.0, 1.5.1, 1.6.0, 1.7.0, 1.7.1, 1.8.0, 1.8.1, 1.9.0)

ERROR: No matching distribution found for torch==1.9.0+cu102

WARNING: You are using pip version 21.1.1; however, version 21.1.2 is available.
You should consider upgrading via the ‘/home/appuser/venv/bin/python -m pip install --upgrade pip’ command.

My requirements.txt has following :

torch == 1.9.0+cu102
torchvision == 0.10.0+cu102

How can I solve this . @Creators

Hi @Bhavya_Soni,

not sure where you are trying to deploy.
But as far as I understand +cu102 defines the CUDA version and in case you are trying
to deploy on Streamlit Sharing, GPU is - to the best of my knowledge - not yet supported (rumors say it is coming some day soon-ish).
So the solution would be to change +cu to +cpu, I guess. Hope that helps.

Stay tuned!

I’m trying to deploy on streamlit it self.Still getting the same error . and It’s also asking for pip upgrade where can I do that on streamlit host?


This should be written no need to write versions.