Can't pick Python3.8 in Advanced Settings

https://share.streamlit.io/deploy

    Advanced settings...
        Python version
            3.7
            3.8
            3.9*
            3.10

When I deploy an app from https://share.streamlit.io/deploy, the Advanced settings presents a list of Python versions I am supposed to be able to select from? Python 3.9 is the default.

I cant seem to be able to select 3.8 (for one reason or another I really need Python 3.8). I tried with Chrome, Firefox and Edge. The same happens: I am redirected to a blank page.

What am I doing wrong? Thanks a lot.

3 Likes

Hi @mikeie, welcome back to the forum!

Thanks for letting us know, this appears to be a bug introduced in a recent update to Streamlit Cloud. The fix for this will be deployed shortly.

Best,
Randy

Thanks Randy

Good to know :+1: