Cloning repository from github failed

Below are my logs :

[     UTC     ] Logs for mallapraveen-document-extr-srcdocumentextractorapiwebapp-x1d5nk.streamlit.app/
ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€
[04:29:21] šŸ–„ Provisioning machine...
[04:29:26] šŸŽ› Preparing system...
[04:29:32] ā›“ Spinning up manager process...
[04:29:39] šŸŽˆ Inflating balloons...
[04:29:46] šŸ“– Unpacking Comic Sans RAR files...
[04:29:51] šŸš§ Loading "Under construction" GIF...
[04:29:58] šŸ›  Compiling <blink> tags...
[04:30:05] šŸ“  Initializing Java applet...
[04:30:12] ā³ Please wait...
[04:29:15] šŸš€ Starting up repository: 'document-extractor', branch: 'main', main module: 'src/documentExtractorAPI/webapp.py'
[04:29:15] šŸ™ Cloning repository...
[04:29:21] šŸ™ failed
[04:29:36] šŸ™ failed
[04:29:53] šŸ™ failed
[04:30:09] šŸ™ failed
[04:30:25] šŸ™ failed
[04:30:35] šŸ™ Failed to download the sources for repository: 'document-extractor', branch: 'main', main module: 'src/documentExtractorAPI/webapp.py'
[04:30:35] šŸ™ Make sure the repository and the branch exist and you have write access to it, and then reboot the app.
[04:32:05] ā—ļø Streamlit server consistently failed status checks
[04:32:05] ā—ļø Please fix the errors, push an update to the git repo, or reboot the app.

I tried deleting the app and reploying. Tried revoking access and granting streamlit access again for github. Still the issue persists

1 Like

Hi @mallapraveen,

Thanks for posting!

Have you tried copying the URL from your webapp.py in GitHub and pasting it to deploy?

ā€¦