Command not found:Streamlit

Hello! I know this question has already been addressed, but I am having major issues with this and it’s stressing me out.
Operating off a macbook pro. Both python 2 and python 3.7 installed on the platform.
Tried installing streamlit with both pip and pip3 --> success! But when i call streamlit hello on terminal, i get a command not found error. Would really appreciate anyone’s help to triage this issue and help me solve it.


Hello @rrnakada, welcome to the forums :slight_smile:

I’ll be borrowing from another answer first :

Hi @andfanilo!

It turns out that my pip and pip3 had installed streamlit to a different location and in order to call stremlit. I found a work around by typing this is terminal:

source ~/.bash_profile


I am having another problem however. When I run a py file with embrace: streamlit run I am getting this error - see screenshot.

The only problem is - I know that I installed - via pip3 - clickhouse-driver, because when i run this py file as a notebook, the packages are imported without any error.

Woulve love any visibility/help on this issue!

Ray N.

Hi @rrnakada,

For all of the issues you have encountered (and more), we heartily recommend running Streamlit within a virtual environment instead of trying to run from a global install. Python is notoriously finicky with packages.

At Streamlit we use pipenv, which does not come stock with any OS right now, but which should be easy enough to install if you’re on Linux or OS X. On Window most people use Conda environments. Looks to me like you’re on OS X though.

Do have a look at our Installing In a Virtual Environment page and try out the approach of using pipenv, then install streamlit, clickhouse-driver, and so on within the virtual environment. Let us know how it goes!