Dataframe was not working

hi my dataframe was not working, any ideas? its shows 3 box with type to search


s

Hi @viswa

Could you provide additional context and the code snippet for reproducing this error.

Thanks!

any kind of dataframe i gave it will show output like this only. if same i gave as st.table it shows the data in the table format
code:
data = {
‘Fruit’: [‘Apple’, ‘Banana’, ‘Cherry’, ‘Date’, ‘Elderberry’],
‘Quantity’: [10, 15, 20, 25, 30],
‘Price’: [0.5, 0.25, 0.75, 1.0, 2.0]
}
df = pd.DataFrame(data)
st.write(“Dataframe Format”)
st.dataframe(df)
st.write(“Table Format”)
st.table(df)

Works fine for me – could you please share what version of streamlit you are using, and if there are any errors logged when running streamlit?

Yes, it functions properly for everyone else, but it does not work in my system. I was unable to make it right.
My Streamlit Version : Streamlit, version 1.29.0
No, I didnt get any errors logged. i get like this only

You can now view your Streamlit app in your browser.

Local URL: http://localhost:8501
Network URL: http://192.168.0.102:8501

The streamlit option menu is not functioning, just like the dataframe. I installed streamlit_option_menu.(pip install streamlit-option-menu)
version: streamlit-option-menu 0.3.6

code:
from streamlit_option_menu import option_menu

with st.sidebar:
selected = option_menu(“Menu”, “Home”, ‘Settings’],
icons=[‘house’, ‘gear’], default_index=0)

if selected == “Home”:
st.write(“home”)
else:
st.write(“settings”)

Could you look in your browser’s developer tools and load the page and see if there are any errors shown? Here are the instructions for Chrome Chrome DevTools खोलें  |  Chrome for Developers

Here I attach the screenshot. it shows only warning message, not error message


Sorry, that’s very strange – I’ve never seen that before. You could try using a different browser, or editing your app in codespaces Develop Streamlit apps in-browser with GitHub Codespaces

I also gave it a try using Opera. Just like this, it displays the same. any firewall or configuration problems?

Could you check the network tab and see if anything was blocked?

no it was not blocked. i checked

[quote=“iamunik, post:13, topic:56916, full:true”]
@viswa I also have this issue and I haven’t found a solution, I tried downgrading my streamlit version maybe the newer one had a fault… idk… but it was the same, I have used every browser I have on my system also it is the showing the same thing. Have you been able to get a solution? I have exhausted every option I have.

No, I also tried many things. For me, st.write(df) [df is Dataframe Name] given like this will work. Just try it

1 Like