I thank you for your help.
I am having issues with my first app/dashboard.
I eliminated several dependencies from Windows exclusively, and solved other problems by eliminating the version number, but I never managed to deploy it.

I thank you for the time :smiley:

If you’re creating a debugging post, please include the following info:

  1. Deployed App
  2. on Community Cloud
    b. Share the link to the public deployed app (
  3. Share the link to your app’s public GitHub repository (including a requirements file).
  4. Share the full text of the error message (not a screenshot).
And because any of:



      depends on flatbuffers>=23.5.26 and you require flatbuffers==1.12, we

      can conclude that you require==0a0.dev0, any of:


      , any of:



      , any of:




      , all versions of tensorflow are incompatible.
      And because you require keras==2.9.0 and tensorflow, we can conclude

      that you require==0a0.dev0, any of:



      , any of:



       are incompatible.

      And because you require tensorflow-estimator==2.9.0 and

      typing-extensions==4.11.0, we can conclude that the requirements are


      hint: Pre-releases are available for tensorflow in the requested

      range (e.g., 2.16.0rc0), but pre-releases weren't enabled (try:

  1. Share the Streamlit and Python versions.
    Python 3.11.19
    Streamlit, latst version

Cheers! :smiley:

Why are you even trying to install those packages?

Your requirements file is crammed with unnecessary packages, clean it up, keep only those, you actually import in your app.

HI there, thanks for the comment. This helped a lot, although not yet clear from the fire. I am now running into another issue.

  Downloading psycopg2-2.9.9.tar.gz (384 kB) 384.9/384.9 kB 37.0 MB/s eta 0:00:00

  Preparing metadata ( started

  Preparing metadata ( finished with status 'error'

  error: subprocess-exited-with-error

  × python egg_info did not run successfully.

  │ exit code: 1

  ╰─> [23 lines of output]

      running egg_info

      creating /tmp/pip-pip-egg-info-zlyl27le/psycopg2.egg-info

      writing /tmp/pip-pip-egg-info-zlyl27le/psycopg2.egg-info/PKG-INFO

      writing dependency_links to /tmp/pip-pip-egg-info-zlyl27le/psycopg2.egg-info/dependency_links.txt

      writing top-level names to /tmp/pip-pip-egg-info-zlyl27le/psycopg2.egg-info/top_level.txt

      writing manifest file '/tmp/pip-pip-egg-info-zlyl27le/psycopg2.egg-info/SOURCES.txt'

      Error: pg_config executable not found.

      pg_config is required to build psycopg2 from source.  Please add the directory

      containing pg_config to the $PATH or specify the full executable path with the


          python build_ext --pg-config /path/to/pg_config build ...

      or with the pg_config option in 'setup.cfg'.

      If you prefer to avoid building psycopg2 from source, please install the PyPI

      'psycopg2-binary' package instead.

      For further information please check the 'doc/src/install.rst' file (also at


      [end of output]

  note: This error originates from a subprocess, and is likely not a problem with pip.

error: metadata-generation-failed

× Encountered error while generating package metadata.

╰─> See above for output.

note: This is an issue with the package mentioned above, not pip.

hint: See above for details.

I am not sure how to proceed from here.
I thank you for the comment


Hi there,

I thank you for the answer, I already added it to the requirements.txt but I seem to have the same problem.

My requirements.txt looks like this


I thank you for the help again.

  • you probably don’t need psycopg2-binary at all?
  • you probably don’t need queries at all?
  • you have in your repo and queries in your requirements, this won’t work

Fixed! It all works now.
I thank you a lot for your time.

Many greetings :smiley:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.