Deploy error when try install arcgis api

I have tried deploy my app with streamlit cloud I’m using requirements.txt file the below error message appears when trying to install arcgis package.

The error message is:

Collecting gssapi

  Downloading gssapi-1.7.3.tar.gz (1.3 MB)

     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 1.3/1.3 MB 246.2 MB/s eta 0:00:00[2022-07-26 13:29:25.299340] 

  Preparing metadata (setup.py): started

  Preparing metadata (setup.py): finished with status 'error'

  error: subprocess-exited-with-error

  

  × python setup.py egg_info did not run successfully.

  │ exit code: 1

  ╰─> [14 lines of output]

      In distributed package, building from C files...

      /bin/sh: 1: krb5-config: not found

      Traceback (most recent call last):

        File "<string>", line 2, in <module>

        File "<pip-setuptools-caller>", line 34, in <module>

        File "/tmp/pip-install-vj__yekb/gssapi_0e884d0171e346fa98bb9e49b47b780f/setup.py", line 128, in <module>

          link_args = shlex.split(get_output(f"{kc} --libs gssapi"))

        File "/tmp/pip-install-vj__yekb/gssapi_0e884d0171e346fa98bb9e49b47b780f/setup.py", line 41, in get_output

          res = subprocess.check_output(*args, shell=True, **kwargs)

        File "/usr/local/lib/python3.9/subprocess.py", line 424, in check_output

          return run(*popenargs, stdout=PIPE, timeout=timeout, check=True,

        File "/usr/local/lib/python3.9/subprocess.py", line 528, in run

          raise CalledProcessError(retcode, process.args,

      subprocess.CalledProcessError: Command 'krb5-config --libs gssapi' returned non-zero exit status 127.

      [end of output]

  

  note: This error originates from a subprocess, and is likely not a problem with pip.

error: metadata-generation-failed


× Encountered error while generating package metadata.

╰─> See above for output.


note: This is an issue with the package mentioned above, not pip.

hint: See above for details.

requirements.txt:

arcgis==2.0.1
folium
matplotlib
mapclassify
geopandas==0.11.0
numpy==1.23.1
pandas==1.4.3
streamlit==1.11.0
streamlit_folium==0.6.14

I also tried utilize environment.yml (Conda) but without success.

environment.yml

name: dashboard
channels:
  - conda-forge
  - esri
dependencies:
  - python=3.9
  - arcgis
  - folium
  - matplotlib
  - mapclassify
  - pip
  - pip:
    - geopandas
    - streamlit
    - streamlit-folium

Error mensage

Collecting package metadata (repodata.json): ...working... [2022-07-26 13:37:56.023537] done

[13:39:30] ❗️ installer returned a non-zero exit code

[13:39:30] ❗️ Error during processing dependencies! Please fix the error and push an update, or try restarting the app.

[13:41:07] ❗️ Streamlit server consistently failed status checks

[13:41:07] ❗️ Please fix the errors, push an update to the git repo, or reboot the app.