Deployement issue: Error installing requirements

deployment failed due to an error installation of requirements.

streamlit==0.71.0
pandas==1.1.3
base58==2.0.1
subprocess
os
pickle

Hi @neelakandan_rakesh, can you share the full error message?

@Caroline it says Error installing requirements.
no other errors

@neelakandan_rakesh When signed in as a deverloper, you can view the entire traceback and error message in your Cloud logs.

The solution is to only include packages in your requirements file that are not distributed with a standard Python installation. i.e. packages not part of The Python Standard Library.

os, subprocess, and pickle are in The Python Standard Library, and hence must be excluded.

Also, is there any particular reason you’re using an ancient version of Streamlit released in 2020? To take advantage of the latest security updates, bug fixes, and features released since 2020, I would encourage you to update to the latest version of as of writing: streamlit==1.12.2.

Happy Streamlit-ing! :balloon:
Snehan

1 Like

thanks man. tried excluding the package os, subprocess and pickle. but now the app gets struck on “Spinning up manager process…”. any ideas.
my github link:
https://github.com/NeelakandanAR/Therapeutic-class-ML-model
streamlit app link:
https://neelakandanar-therapeutic-class-ml-model-app-8cv7sa.streamlitapp.com/

+1 to @snehankekre’s suggestion – upgrade your Streamlit version to the most recent version. Also, it looks like your repo is private so unfortunately we can’t take a look

hi caroline. as per ur recomendation has removed subprocess, os and pickle. however a new error occurred
showing file not found error. have attached the error message

my github link: GitHub - NeelakandanAR/RGK_Pway_classification-: app to predict the pathway type of the given drugs