Env: ‘/home/appuser/venv/bin/streamlit’: No such file or directory

Hello, I am facing this error and no idea how to solve it or what it means.


This is the github: https://github.com/Nabil-Miri/mystreamlit

Hi @Nabil-Miri, welcome to the forum!

That github URL doesn’t work for me – is that a private app?

My first suggestion, without having seen the app, is to try restarting the app, and if that doesn’t work, then try deleting and re-deploying. Can you see if either of those work?

Hello,
Sorry it was private and I made it public.

I tried restarting and deleting but same error.

It looks like it might be because of your dendron2 entry in requirements.txt – from what I’ve read, the official instructions aren’t to install from github, but from their custom index.

Can you try putting this in your requirements.txt instead?

--extra-index-url https://dl.fbaipublicfiles.com/detectron2/wheels/cu113/torch1.10/index.html
detectron2

Did you mean like this?

I got:

I removed “detectron2” from the requirments and nothing changed:

BTW the same code have worked before using this git: GitHub - Nabil-Miri/streamlit_pytorch_detectron2: Streamlit an open source library used to make data apps really easily. In this I am trying to deploy a detectron2 pytorch model through streamlit
app: https://nabil-miri-streamlit-pytorch-detectron2-main-j6z86x.streamlit.app/
But when I cloned it, it didn’t work and the no such file error showed up.

Update: I have solved the issue by including ‘streamlib’ in the requirments.txt

1 Like