Error deploying app - "Error checking Streamlit healthz" connection refused

Hi all - hoping someone can help me with this issue. My app worked fine when I ran it on localhost, but today when I tried to use Streamlit sharing I am having an issue.

“Error checking Streamlit healthz: Get “http://localhost:8501/healthz”: dial tcp 127.0.0.1:8501: connect: connection refused”

Any idea why this happens? I believe it has something to do with the word2vec gensim model I am using.

Github: GitHub - hschrei7/codenamesbot

Streamlit app: https://share.streamlit.io/hschrei7/codenamesbot/main/main.py

Hi @hschreib -

Has this app ever worked on Streamlit sharing? We had a brief outage yesterday, which caused some people’s apps to be in an uncertain state, which is solved by rebooting the app.

If it has never worked/didn’t work on the first deployment, it could be the case that the model you are using is exhausting the available resources. Do you have an idea of how large the model you are loading is?

Best,
Randy

Hi @randyzwitch - unfortunately it has yet to ever work in Streamlit sharing (tried again just now).

I’m trying to use a pretrained, off-the-shelf word2vec model (word2vec-google-news-300), which is 1662.8MB (seems to download ok according to the logs?). Does this exhaust available resources?

Yes. The total container size needs to be 800MB or less in the free tier.

https://docs.streamlit.io/en/stable/deploy_streamlit_app.html#resource-limits

Apps get up to 1 CPU, 800 MB of RAM, and 800 MB of dedicated storage in a shared execution environment.

1 Like

Thanks @randyzwitch - my friend and I were able to swap to a less expensive model and get it to work!

1 Like