Error installing requirements for streamlit web app

Hello Streamlit community,

When trying to deploy my streamlit application I keep getting the following error:

ERROR: Could not find a version that satisfies the requirement pandas==1.4.1 (from versions: 0.1, 0.2, 0.3.0, 0.4.0, 0.4.1, 0.4.2, 0.4.3, 0.5.0, 0.6.0, 0.6.1, 0.7.0, 0.7.1, 0.7.2, 0.7.3, 0.8.0, 0.8.1, 0.9.0, 0.9.1, 0.10.0, 0.10.1, 0.11.0, 0.12.0, 0.13.0, 0.13.1, 0.14.0, 0.14.1, 0.15.0, 0.15.1, 0.15.2, 0.16.0, 0.16.1, 0.16.2, 0.17.0, 0.17.1, 0.18.0, 0.18.1, 0.19.0, 0.19.1, 0.19.2, 0.20.0, 0.20.1, 0.20.2, 0.20.3, 0.21.0, 0.21.1, 0.22.0, 0.23.0, 0.23.1, 0.23.2, 0.23.3, 0.23.4, 0.24.0, 0.24.1, 0.24.2, 0.25.0, 0.25.1, 0.25.2, 0.25.3, 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.1.0, 1.1.1, 1.1.2, 1.1.3, 1.1.4, 1.1.5, 1.2.0, 1.2.1, 1.2.2, 1.2.3, 1.2.4, 1.2.5, 1.3.0, 1.3.1, 1.3.2, 1.3.3, 1.3.4, 1.3.5)
ERROR: No matching distribution found for pandas==1.4.1
WARNING: You are using pip version 22.0.3; however, version 22.0.4 is available.
You should consider upgrading via the '/home/appuser/venv/bin/python -m pip install --upgrade pip' command.
[manager] installer returned a non-zero exit code
[manager] Error during processing dependencies! Please fix the error and push an update, or try restarting the app.

I tried uninstalling and reinstalling pandas and it still did not work. The web app runs fine locally, the error message appears during deployment. Here is the project repo.

Any suggestions are greatly appreciated.

What is your local Python version?
Do you specifically need Pandas Version 1.4.1 ?
Since Pandas version 1.4.x there are only packages for Python 3.8+ in the pypi repository available.
I think that the streamlit cloud runtime runs on Python 3.7 and therefore no package could be found.
If you don’t need this pandas version explicitly, just leave out the pandas version or take the last valid version in your requirements.txt file:

pandas

or

pandas==1.3.5
1 Like

I changed the pandas version to 1.3.5 in the requirements.txt and that did the job. Thanks, Franky!

1 Like

Question was resolved, but also important to note that you can pick the Python version upon app deployment, so if Python 3.7 - 3.9 is required, you can choose so. New versions of Python will get added as they are released/tested

Best,
Randy

1 Like