Error installing requirements - protobuf

I get this error - I don`t know how to get new version of protobuf

ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
tensorflow-cpu 2.12.0 requires protobuf!=4.21.0,!=4.21.1,!=4.21.2,!=4.21.3,!=4.21.4,!=4.21.5,<5.0.0dev,>=3.20.3, but you have protobuf 3.20.1 which is incompatible.
Successfully installed protobuf-3.20.1
WARNING: You are using pip version 22.0.3; however, version 23.1.2 is available.
You should consider upgrading via the '/home/appuser/venv/bin/python -m pip install --upgrade pip' command.

Hi @Stas_Rubtsov – please see this post for an answer to your question Why is protobuf forced installed in version 3.20.1? - #16 by blackary

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.