Error message when launching streamlit program

Hi i have a news message when I tried to launch my program Home.py. What I do not understand is that yesterday everything worked fine…I just did Conda update --all

Here is the error message:

(data) jacques@MacBook-Pro ~ % streamlit run "/Users/jacques/Library/Mobile Documents/com~apple~CloudDocs/Projets/Quantalys/Home.py"
Traceback (most recent call last):
  File "/Users/jacques/opt/anaconda3/envs/data/bin/streamlit", line 5, in <module>
    from streamlit.web.cli import main
  File "/Users/jacques/opt/anaconda3/envs/data/lib/python3.10/site-packages/streamlit/__init__.py", line 56, in <module>
    from streamlit.delta_generator import DeltaGenerator as _DeltaGenerator
  File "/Users/jacques/opt/anaconda3/envs/data/lib/python3.10/site-packages/streamlit/delta_generator.py", line 55, in <module>
    from streamlit.elements.image import ImageMixin
  File "/Users/jacques/opt/anaconda3/envs/data/lib/python3.10/site-packages/streamlit/elements/image.py", line 31, in <module>
    from PIL import GifImagePlugin, Image, ImageFile
  File "/Users/jacques/opt/anaconda3/envs/data/lib/python3.10/site-packages/PIL/GifImagePlugin.py", line 33, in <module>
    from . import Image, ImageChops, ImageFile, ImagePalette, ImageSequence
  File "/Users/jacques/opt/anaconda3/envs/data/lib/python3.10/site-packages/PIL/Image.py", line 82, in <module>
    from . import _imaging as core
ImportError: dlopen(/Users/jacques/opt/anaconda3/envs/data/lib/python3.10/site-packages/PIL/_imaging.cpython-310-darwin.so, 0x0002): Library not loaded: @rpath/libtiff.5.dylib
  Referenced from: <7352BC54-ABDE-357E-8163-397B38DD1E2F> /Users/jacques/opt/anaconda3/envs/data/lib/python3.10/site-packages/PIL/_imaging.cpython-310-darwin.so
  Reason: tried: '/Users/jacques/opt/anaconda3/envs/data/lib/python3.10/site-packages/PIL/../../../libtiff.5.dylib' (no such file), '/Users/jacques/opt/anaconda3/envs/data/lib/python3.10/site-packages/PIL/../../../libtiff.5.dylib' (no such file), '/Users/jacques/opt/anaconda3/envs/data/bin/../lib/libtiff.5.dylib' (no such file), '/Users/jacques/opt/anaconda3/envs/data/bin/../lib/libtiff.5.dylib' (no such file), '/usr/local/lib/libtiff.5.dylib' (no such file), '/usr/lib/libtiff.5.dylib' (no such file, not in dyld cache)

The streamlite version I have is:

(data) jacques@MacBook-Pro ~ % conda list streamlit
# packages in environment at /Users/jacques/opt/anaconda3/envs/data:
#
# Name                    Version                   Build  Channel
streamlit                 1.28.0                   pypi_0    pypi
streamlit-aggrid          0.3.4.post3              pypi_0    pypi
streamlit-camera-input-live 0.2.0                    pypi_0    pypi
streamlit-card            0.0.4                    pypi_0    pypi
streamlit-embedcode       0.1.2                    pypi_0    pypi
streamlit-extras          0.2.6                    pypi_0    pypi
streamlit-faker           0.0.2                    pypi_0    pypi
streamlit-image-coordinates 0.1.3                    pypi_0    pypi
streamlit-keyup           0.2.0                    pypi_0    pypi
streamlit-toggle-switch   1.0.2                    pypi_0    pypi
streamlit-vertical-slider 1.0.2                    pypi_0    pypi