Error running app when deploy. Could be a Memory managing problem

My app fail when I deploy it, but works well on my PC (using anaconda).

This is my App link:

https://share.streamlit.io/arnaudimai/clip-guesswho/main/app_qesq_v7.pyProcessing: app_qesq_v7_original.py…

This is the GitHub file:

1 Like

Hi @ArnauDIMAI

Nice app!

I’ve tried it and it doesn’t crash on my end.

Have you got an error log of what happened?

Thanks
Charly

Hello, thank’s for your quickly response.

Can you use the app, reach the end (the final punctuation) and start a new game without problems?

When I try it, some times I finish the game, but in general the errors appears with this logs:

Final Logs:

Successfully installed ftfy-6.0.3 numpy-1.21.2 pillow-8.3.1 regex-2021.8.3 torch-1.9.0 torchvision-0.10.0 typing-extensions-3.10.0.0 wcwidth-0.2.5
e[35mWARNINGe[0m: You are using pip version 21.1.1; however, version 21.2.4 is available.
You should consider upgrading via the ‘/home/appuser/venv/bin/python -m pip install --upgrade pip’ command.
e[32m[manager] e[0mPython dependencies were installed from /app/clip-guesswho/requirements.txt using pip.
e[32m[manager] e[0mProcessed dependencies!
e[32m[manager] e[0mStreamlit server consistently failed status checks
e[32m[manager] e[0mPlease fix the errors, push an update to the git repo, or reboot the app.

I just realized that you shouldn’t use cache to save game data, you should use session (session_state). I has changed it in the version 8 of the app. But the same error appears again some times. Testing the app in local mode with Anaconda, I have never seen the error.

I try to improve the app with this version, but the same error appears:

App link:
https://share.streamlit.io/arnaudimai/clip-guesswho/main/app_qesq_v9.py

Logs:
[manager] Starting up for owner: ‘arnaudimai’, repository: ‘clip-guesswho’, branch: ‘main’, main module: ‘app_qesq_v9.py’
[manager] Cloning repository …
[manager] Cloning into ‘clip-guesswho’…
[manager] Cloned repository!
[manager] Processing dependencies …
Looking in links: https://download.pytorch.org/whl/torch_stable.html
Collecting ftfy
Downloading ftfy-6.0.3.tar.gz (64 kB)
[client] Preparing system…
[client] Spinning up manager process…
Collecting regex
Downloading regex-2021.8.28-cp37-cp37m-manylinux_2_17_x86_64.manylinux2014_x86_64.whl (745 kB)
Collecting numpy
Downloading numpy-1.21.2-cp37-cp37m-manylinux_2_12_x86_64.manylinux2010_x86_64.whl (15.7 MB)
Collecting pip==21.2.4
Downloading pip-21.2.4-py3-none-any.whl (1.6 MB)
Collecting torch==1.9.0+cpu
Downloading https://download.pytorch.org/whl/cpu/torch-1.9.0%2Bcpu-cp37-cp37m-linux_x86_64.whl (175.5 MB)
Collecting torchvision==0.10.0+cpu
Downloading https://download.pytorch.org/whl/cpu/torchvision-0.10.0%2Bcpu-cp37-cp37m-linux_x86_64.whl (15.7 MB)
Collecting typing-extensions
Downloading typing_extensions-3.10.0.2-py3-none-any.whl (26 kB)
Collecting pillow>=5.3.0
Downloading Pillow-8.3.2-cp37-cp37m-manylinux_2_17_x86_64.manylinux2014_x86_64.whl (3.0 MB)
Collecting wcwidth
Downloading wcwidth-0.2.5-py2.py3-none-any.whl (30 kB)
Building wheels for collected packages: ftfy
Building wheel for ftfy (setup.py): started
Building wheel for ftfy (setup.py): finished with status ‘done’
Created wheel for ftfy: filename=ftfy-6.0.3-py3-none-any.whl size=41933 sha256=6def9a5d9aaab6ad954eb29c9a06f10dac514b91b3a4f6ad9ec53caeb0ac6963
Stored in directory: /tmp/pip-ephem-wheel-cache-n90c6pfl/wheels/19/f5/38/273eb3b5e76dfd850619312f693716ac4518b498f5ffb6f56d
Successfully built ftfy
Installing collected packages: typing-extensions, wcwidth, torch, pillow, numpy, torchvision, regex, pip, ftfy
Attempting uninstall: typing-extensions
Found existing installation: typing-extensions 3.10.0.2
Uninstalling typing-extensions-3.10.0.2:
Successfully uninstalled typing-extensions-3.10.0.2
Attempting uninstall: wcwidth
Found existing installation: wcwidth 0.2.5
Uninstalling wcwidth-0.2.5:
Successfully uninstalled wcwidth-0.2.5
Attempting uninstall: pillow
Found existing installation: Pillow 8.3.2
Uninstalling Pillow-8.3.2:
Successfully uninstalled Pillow-8.3.2
Attempting uninstall: numpy
Found existing installation: numpy 1.21.2
Uninstalling numpy-1.21.2:
Successfully uninstalled numpy-1.21.2
Attempting uninstall: pip
Found existing installation: pip 21.1.1
Uninstalling pip-21.1.1:
Successfully uninstalled pip-21.1.1
Successfully installed ftfy-6.0.3 numpy-1.21.2 pillow-8.3.2 pip-21.2.4 regex-2021.8.28 torch-1.9.0+cpu torchvision-0.10.0+cpu typing-extensions-3.10.0.2 wcwidth-0.2.5
[manager] Python dependencies were installed from /app/clip-guesswho/requirements.txt using pip.
[manager] Processed dependencies!

[client] Connecting…

[manager] Streamlit server consistently failed status checks
[manager] Please fix the errors, push an update to the git repo, or reboot the app.