Error Running Streamlit


I’m running into a strange error that popped up just today. I’ve been able to run my app I built successfully before and have made no changes before trying it today.

I run:
!streamlit run <app name>

This is the error I get.

Traceback (most recent call last):
  File "/anaconda3/bin/streamlit", line 6, in <module>
    from streamlit.cli import main
  File "/anaconda3/lib/python3.7/site-packages/streamlit/", line 34, in <module>
    import streamlit.bootstrap as bootstrap
  File "/anaconda3/lib/python3.7/site-packages/streamlit/", line 30, in <module>
    from streamlit.server.Server import Server
  File "/anaconda3/lib/python3.7/site-packages/streamlit/server/", line 36, in <module>
    from streamlit.ReportSession import ReportSession
  File "/anaconda3/lib/python3.7/site-packages/streamlit/", line 42, in <module>
    from import S3Storage as Storage
  File "/anaconda3/lib/python3.7/site-packages/streamlit/storage/", line 24, in <module>
    import boto3
  File "/anaconda3/lib/python3.7/site-packages/boto3/", line 16, in <module>
    from boto3.session import Session
  File "/anaconda3/lib/python3.7/site-packages/boto3/", line 17, in <module>
    import botocore.session
  File "/anaconda3/lib/python3.7/site-packages/botocore/", line 30, in <module>
    import botocore.credentials
  File "/anaconda3/lib/python3.7/site-packages/botocore/", line 26, in <module>
    from dateutil.parser import parse
  File "/anaconda3/lib/python3.7/site-packages/dateutil/", line 158
    l.append("%s=%s" % (attr, `value`))
SyntaxError: invalid syntax

I’ve also tried reinstalling streamlit and this did not work. I also tried !streamlit hello and get the same error. Is anyone else running into the same issue? How do I resolve this?

Hi @vnguyendc,

What version of dateutil are you using?

Could you try upgrading it?

pip install python-dateutil --upgrade