Error while running streamlit hello

So I had just installed streamlit yesterday and it working all fine. All of sudden it doesn’t work now. streamlit hello throws some error which I am unable to understand. Please help!

Hello @dhairyap99,

I think you modified your Streamlit configuration file config.toml, either in your_project_dir/.streamlit/config.toml or ~/.streamlit/config.toml, and inputted a character somewhere in it. This character seems to be invalid, thus you’re adviced to quote the value containing it.

2 Likes

Hello @Synode,

I tried locating config.toml but couldn’t find the location of the file. Even running the command streamlit config show throws the same error as above. Is there a way out?

Is there a way to completely remove streamlit from the system?
pip uninstall streamlit doesn’t help :confused:

Configuration files won’t necessary be removed when you uninstall a python package.

As you’re on Windows, could you run the following command in your command prompt? It will search for config.toml configuration files on your drive.

dir /s C:\config.toml

If I’m right, you should have a match inside a .streamlit folder, in your home or your project’s directory. Once you have it, could you post its content here?

1 Like

@Synode Thanks I could finally locate the file.

Here’s the content from my config.toml file: “[server]nheadless = truenport = nenableCORS=falsenn“
What do I do?

Hmm, I thought I’d find a in it, but it’s not the case :thinking:

You didn’t have any other match while running dir /s ...? If not, try running streamlit run hello again, and if you’re still encountering the same exception, rename the configuration file to something like backup.toml and run streamlit run hello again.

1 Like

@Synode

Buddy a big thanks!
I renamed the file to backup.toml and streamlit run command works just like it used to. I believe my attempt of hosting it on heroku caused all this trouble. Anyway it is resolved for now and works!

2 Likes

I realize this has already been marked solve, but the way that code snippet is displaying on my computer, it indicates that “smart quotes” are being used rather than plain ' or ". For future people, be careful if you are copy-pasting from somewhere, smart quotes have caused many errors across many programming languages :slight_smile: