Error

I am running for the first time & encountered an error, which says (Error: --browser.gatherUsageStats option requires an argument) after I run the command streamlit run app.py --browser.gatherUsageStats in my terminal.
Can someone tell me where am I wrong?

Hi @Learner, welcome to the forum :slight_smile:

I believe you are missing the argument for the flag, it should be

streamlit run app.py --browser.gatherUsageStats false

Fanilo

@andfanilo I ran the command as you’ve directed , but after that nothing appears in my terminal, the cursor simply blinks. Where can be the issue?

Ah…this is more troublesome :confused:

Do you have the same behavior if you run streamlit hello ?

Otherwise what’s your Streamlit version / Python version / Are you using Conda/Pip/Pipenv / OS version ? How did you install Streamlit on your system ?

@andfanilo yeah I find the same behaviour while running streamlit hello
Conda environment
Python 3.7.7
Streamlit, version 0.61.0
Windows 10
pip install streamlit is the only command to install streamlit

Hmmm, I honestly don’t have an idea for now :confused: …are you in a separate conda env by the way ? maybe the streamlit command you installed is not in the same environment as the one you think it is so tries to rely on the wrong dependencies …

You could try creating a new conda environment with a downgraded Streamlit like 0.60.0 ?

Maybe your antivirus is blocking the python.exe from your separate environment (that…actually happened once to me) ?

If you can try again with the procedure from the FAQ…maybe it’ll give you some more ideas