File upload fails with Error: Request failed with status code 403

I have 3 streamlit apps running - everything worked fine as of Tuesday. Today, all of them fail to upload a file (of any size) with Error: Request failed with status code 403. Any help would be appreciated.

(In addition, link change is also a problem)

Thank you!

2 Likes

Exactly the same problem with me. Attached is the screenshot of the file upload button after I tried uploading a file.

Is this error related to the URL change?

I’m also facing the same problem from today.
Is this happening due to the link change? Can anyone advise a solution to this ?

Same problem here.
After some googling I tried putting these in my config.toml:

[server]
maxUploadSize=200
enableXsrfProtection=false

…didn’t work.

1 Like

Same for me, thanks for opening this issue. My app also has the same problem. Runs fine locally, but upload fails on streamlit cloud.

Setting

[server]
enableCORS = false
enableXsrfProtection = false
enableWebsocketCompression = false

Does not help

1 Like

Hey @svenstehle @lasinludwig @ADISH_A.P @alkadriishere @Anna_Sintsova

Thanks for reporting the issue. We are aware of it and have reverted the URL change.

This should work again, but if it’s still an issue, please let us know :slight_smile:

Best,
Charly

2 Likes

Thanks @Charly_Wargnier .It is working now!

1 Like

Great to hear, thanks for confirming @ADISH_A.P!

Thank you for your quick response!

1 Like

Thank you for the fix. I can confirm that it works fully on my side now.

1 Like

Same for me, thanks for the quick fix! It works again :slight_smile:

1 Like

Hello @Charly_Wargnier!

I’m having the same issue today. Maybe I’m doing something different from the guys? I don’t know. Can you help?

Tried update streamlit lib from 1.8 to 1.12 still the same error

1 Like

Hi @jgbalves

Apologies for the slight delay in answering your question. For some reason, your post seemed to have slipped through the net.

I suspect this was a temporary issue which should now be fixed. Would you mind retrying and let us know, please?

If the issue persists, I shall raise a ticket to the Devs asap.

Best wishes,
Charly

Hello @Charly_Wargnier !

All sorted, my url was masking Heroku, so the csrf was catching me :slight_smile: . Now it just redirects to the Heroku url. Thanks for the help!

1 Like

Glad you got it sorted @jgbalves! :raised_hands:

Happy streamlit-ing! :balloon:

Charly

Hello,
I’m using streamlit version 1.12.2 and I still have the same error.

Hello,

Same for me, I have this problem when the app is deployed in Azure.
Locally works fine.

Thank you!

Hello,

Facing the same issue while deploying in streamlit, works fine locally.

@Charly_Wargnier facing the same problem, when deploying on Azure, Locally works fine.
Any help would be highly appreciated.
was working fine a week back.