FileNotFoundError: [Errno 2] No such file or directory: '/Users/hugosilvapereira/Desktop/My Projects/LLM Brand Sentiment Agent/llm_env/bin/'

Hey guys, I’m trying to build my first mvp for an llm. I’m not a developer, although I’ve been working with development teams for over 10 years. I’m mostly using bard and I’m doing this to explore its capabilities. So, I’m using conda as my local environment and I’m trying to deploy my app to Streamlit App Builder. Every time I try to do it, I get the following error:

ileNotFoundError: [Errno 2] No such file or directory: ‘/Users/hugosilvapereira/Desktop/My Projects/LLM Brand Sentiment Agent/llm_env/bin/’
File “/home/adminuser/venv/lib/python3.9/site-packages/streamlit/runtime/scriptrunner/”, line 552, in run_script
exec(code, module.dict)
File “/mount/src/”, line 10, in
with open(activate_this) as file

As far as I’ve seen, the error indicates that the file cannot be found. So far, I’ve tried:

i. moving the Activate file to my my local environment.
ii. removing the activate reference
iii. updating the track_posts reference to open the file using its absolute path.

None of the above worked so far… I’m kinda lost. Anyone can give a hand to the new guy?


Hi @hugofasp!

Thanks for posting and welcome to the Streamlit Community forum!

The error seems to stem from trying to activate a local conda environment from within the app. When deploying to Streamlit Community Cloud, this local environment doesn’t exist there. So, you’re essentially trying to open a file that doesn’t exist on Streamlit’s servers.

Can you share the structure of your project directory? This might help us troubleshoot your issue better.

Something of this sort:

├── modules/                  
│   ├──
│   └──
├── .gitignore                
├── requirements.txt          

Thank you very much Tony. Let me give it a try and I’ll get back to this!