Freezing on initial execution at email prompt

I am not able to execute streamlit locally operating within Anaconda (on linux Pop OS. I had no problems running on Windows).

I tried executing !streamlit hello as well as !streamlit run 00_🏠_Home.py (a simple file in the working directory) within both the qt-console and Spyder command window. In all cases, it asks me to enter my email or leave it blank. I cannot press enter or type any text. The only thing it responds to is β€œctrl+c” to break it.

image

Hi @ngallo1

Instead of running from the qt-console or Spyder command window, can you access your terminal where you can then run the mentioned commands streamlit hello or streamlit run 00_🏠_Home.py.

That worked. From the command line, I am able to bypass the email input. After doing this on my system once, I am then able to call everything from within Anaconda.

Details:

  1. Install streamlit from command line and execute streamlit hello as detailed here: Installation<!-- --> - Streamlit Docs
  2. On Linux, I had to restart my computer before system recognized streamlit command ("streamlit: command not found" on KDE Neon Β· Issue #4845 Β· streamlit/streamlit Β· GitHub)
  3. I was then able to run command !streamlit hello and !streamlit run 00_🏠_Home.py within anaconda terminals without being blocked at the email prompt.
1 Like

Glad that it is working now!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.