Getting Error in running app

pip’s dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
tensorflow 2.11.0 requires protobuf<3.20,>=3.9.2, but you have protobuf 3.20.3 which is incompatible.

This is probably related:

That issue (always installing 3.20.1) has been very recently resolved (yesterday), so this should no longer be an issue.

It will be hard to diagnose the issue further @aryamnkhare without seeing all the packages you are using. Could you share your requirements.txt, or whatever file you are using to specify your dependencies?

1 Like

Hey, Can you please check out my app: It keeps crashing.
My Github repo: GitHub - Martin1998215/summaryai

I will be grateful…

I’m including protobuf version 3.19.6 in req.txt file as i need for running my web app but still streamlit is forcing 3.20.3 version. How to fix this?

Can you try pinning to streamlit==1.22.0 and see if that resolves the issue?

Streamlit latest version available is 1.16. If you are asking for version 1.12 then i tried all versions from 1.10 to 1.16 and getting same error.

No, the latest version available is 1.22.0 Changelog - Streamlit Docs

Getting following error:

The service has encountered an error while checking the health of the Streamlit app: Get “http://localhost:8501/healthz”: dial tcp connect: connection refused

Collecting usage statistics. To deactivate, set browser.gatherUsageStats to False.

That seems unrelated to the original error – is this causing your app to break? Can you share more about what exactly is happening, and what your requirements.txt (or other dependency file) has in it?