Getting error while deploying the app

Please help me deploy this app. https://share.streamlit.io/krishnabakshi1/movie-recommendation-system/main/main.py


[04:42:47] 🐍 Python dependencies were installed from /app/movie-recommendation-system/requirements.txt using pip.
Check if streamlit is installed
Streamlit is already installed
[04:42:49] 📦 Processed dependencies!
Traceback (most recent call last):
  File "/home/appuser/venv/bin/streamlit", line 5, in <module>
    from streamlit.cli import main
  File "/home/appuser/venv/lib/python3.9/site-packages/streamlit/__init__.py", line 48, in <module>
    from streamlit.proto.RootContainer_pb2 import RootContainer
  File "/home/appuser/venv/lib/python3.9/site-packages/streamlit/proto/RootContainer_pb2.py", line 33, in <module>
    _descriptor.EnumValueDescriptor(
  File "/home/appuser/venv/lib/python3.9/site-packages/google/protobuf/descriptor.py", line 755, in __new__
    _message.Message._CheckCalledFromGeneratedFile()
TypeError: Descriptors cannot not be created directly.
If this call came from a _pb2.py file, your generated code is out of date and must be regenerated with protoc >= 3.19.0.
If you cannot immediately regenerate your protos, some other possible workarounds are:
 1. Downgrade the protobuf package to 3.20.x or lower.
 2. Set PROTOCOL_BUFFERS_PYTHON_IMPLEMENTATION=python (but this will use pure-Python parsing and will be much slower).

More information: https://developers.google.com/protocol-buffers/docs/news/2022-05-06#python-updates
[04:42:50] ❗️ error restarting streamlit: exit status 7: output: streamlit: ERROR (not running)
streamlit: ERROR (spawn error)
[04:42:50] ❗️ Error during processing dependencies! Please fix the error and push an update, or try restarting the app.
[04:44:21] ❗️ Streamlit server consistently failed status checks
[04:44:21] ❗️ Please fix the errors, push an update to the git repo, or reboot the app.

Hi @Krishna_Bakshi, welcome to the Streamlit community!

This was a dependency issue in Streamlit, which was resolved by Streamlit 1.9.2 (the newest version. as of writing this message). If you set streamlit >= 1.9.2 in your requirements.txt file, that should resolve the issue.

Best,
Randy