Getting weird OS Error when I try to import my repo into shar.streamlit

Any ideas what is causing this?

Processing /home/ktietz/src/ci/alabaster_1611921544520/work
ERROR: Could not install packages due to an OSError: [Errno 2] No such file or directory: '/home/ktietz/src/ci/alabaster_1611921544520/work'

Hello @aodev95, welcome to the community!

Could you give us more details on your problem? We will need more info to be able to help you:

  • On which platform are you trying to deploy?
  • How are you installing your libraries? Do you use a requirements file?
  • Do you have a link to your project?

Cheers,
Fanilo :balloon:

I would guess that your requirements.txt file has directory-specific Python packages, which won’t work when you move to a separate machine. That’s where I’d start, removing any filepaths from your requirements.txt.

Best,
Randy

1 Like

This worked! When I ran “pip freeze > requirements.txt” it gave me a bunch of libraries I didn’t need and included file locations. I simply created a blank requirements.txt file and listed off the python modules I used in the script. Thanks for your help!

1 Like