Help -> Previously working Streamlit but now only getting module 'toml' has no attribute 'dump'

I have been testing out Streamlit recently and have been really happy with it. Went to access via Anaconda cmd prompt and now I keep getting “module ‘toml’ has no attribute ‘dump’”.

Did a few searches and it seemed like most people were recommending changing the file name and that it would work. Tried that and didn’t work. Can’t even get >streamlit hello working now. Any suggestions / help?

I’ve tried uninstalling / reinstalling the library with no success.

Here’s what I was using earlier today / yesterday that was running just fine and now won’t pull up for the same reason:

Hi @Tstark14, welcome to the forum !

It’s nice you’re using Anaconda to manage Python on Windows. Though I see on the screenshot you’re using the (base) environment, which is the default environment so maybe conda has installed a package that broke a Streamlit dependency between yesterday and today.

What you can do (and is also the recommended way to use Anaconda) is create a separate conda environment, different from (base), which will only contain Streamlit and its dependencies, so that things you install in base don’t break Streamlit in the separate environment. You can find the process on the FAQ page of Streamlit, tell us if that worked for you !


1 Like

Thank you @andfanilo! Easy enough to follow, got things working and super pumped!

Appreciate the help!