Help! Streamlit server consistently failed status checks

Receiving the message “Streamlit server consistently failed status checks” when trying to deploy my app. Have spent a lot of time rewriting code to condense it to see if that was the issue but still no luck. The app works just fine and boots quickly locally but I just haven’t been able to get it to deploy.

Please let me know if there are any glaring issues in my files or my code that would cause this. Thank you in advance.

My github repo is here: GitHub - cody8522/ticketmodel

Use the latest streamlit>=1.10.0 version.

I am now getting “installer returned a non-zero exit code” after adding streamlit >= 1.10.0 to my requirements.txt. Would you know which of my requirements might be incompatible with this version of streamlit?

I don’t know without any error message or without trying it myself.

  • What is the error message (no screenshots please)?
  • You could also remove all the version numbers from the requirements.txt file and try again, then pip will try to resolve the dependencies itself.

Attempting uninstall: streamlit
Found existing installation: streamlit 1.8.1
Uninstalling streamlit-1.8.1:
Successfully uninstalled streamlit-1.8.1
Successfully installed MarkupSafe-2.1.1 Send2Trash-1.8.0 altair-4.2.0 argon2-cffi-21.3.0 argon2-cffi-bindings-21.2.0 attrs-21.4.0 backcall-0.2.0 backports.zoneinfo-0.2.1 beautifulsoup4-4.11.1 bleach-5.0.1 blinker-1.4 cachetools-5.2.0 certifi-2022.6.15 cffi-1.15.1 charset-normalizer-2.1.0 click-8.1.3 commonmark-0.9.1 debugpy-1.6.1 decorator-5.1.1 defusedxml-0.7.1 entrypoints-0.4 fastjsonschema-2.15.3 gitdb-4.0.9 gitpython-3.1.27 idna-3.3 importlib-metadata-4.12.0 importlib-resources-5.8.0 ipykernel-6.15.0 ipython-7.34.0 ipython-genutils-0.2.0 ipywidgets-7.7.1 jedi-0.18.1 jinja2-3.1.2 joblib-1.1.0 jsonschema-4.6.1 jupyter-client-7.3.4 jupyter-core-4.10.0 jupyterlab-pygments-0.2.2 jupyterlab-widgets-1.1.1 matplotlib-inline-0.1.3 mistune-0.8.4 nbclient-0.6.6 nbconvert-6.5.0 nbformat-5.4.0 nest-asyncio-1.5.5 notebook-6.4.12 numpy-1.21.6 packaging-21.3 pandas-1.3.5 pandocfilters-1.5.0 parso-0.8.3 pexpect-4.8.0 pickleshare-0.7.5 pillow-9.2.0 prometheus-client-0.14.1 prompt-toolkit-3.0.30 protobuf-3.20.1 psutil-5.9.1 ptyprocess-0.7.0 pyarrow-8.0.0 pycparser-2.21 pydeck-0.7.1 pygments-2.12.0 pympler-1.0.1 pyparsing-3.0.9 pyrsistent-0.18.1 python-dateutil-2.8.2 pytz-2022.1 pytz-deprecation-shim-0.1.0.post0 pyzmq-23.2.0 requests-2.28.1 rich-12.4.4 scikit_learn-1.0.2 scipy-1.7.3 semver-2.13.0 setuptools-63.1.0 six-1.16.0 smmap-5.0.0 soupsieve-2.3.2.post1 streamlit-1.10.0 terminado-0.15.0 threadpoolctl-3.1.0 tinycss2-1.1.1 toml-0.10.2 toolz-0.11.2 tornado-6.2 traitlets-5.3.0 typing-extensions-4.3.0 tzdata-2022.1 tzlocal-4.2 urllib3-1.26.9 validators-0.20.0 watchdog-2.1.9 wcwidth-0.2.5 webencodings-0.5.1 widgetsnbextension-3.6.1 xgboost-1.6.1 zipp-3.8.0
WARNING: You are using pip version 22.0.3; however, version 22.1.2 is available.
You should consider upgrading via the ‘/home/appuser/venv/bin/python -m pip install --upgrade pip’ command.
Checking if Streamlit is installed
Found Streamlit version 1.10.0 in the environment
Streamlit 1.10.0 is present. Installing click 8
Collecting click==8
Downloading click-8.0.0-py3-none-any.whl (96 kB)
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 96.9/96.9 KB 5.9 MB/s eta 0:00:00[2022-07-07 14:04:35.197897]
Installing collected packages: click
Attempting uninstall: click
Found existing installation: click 8.1.3
Uninstalling click-8.1.3:
Successfully uninstalled click-8.1.3
Successfully installed click-8.0.0
WARNING: You are using pip version 22.0.3; however, version 22.1.2 is available.
You should consider upgrading via the ‘/home/appuser/venv/bin/python -m pip install --upgrade pip’ command.
Streamlit 1.10.0 is present. Installing protobuf 3.20.1
Collecting protobuf==3.20.1
Downloading protobuf-3.20.1-cp37-cp37m-manylinux_2_5_x86_64.manylinux1_x86_64.whl (1.0 MB)
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 1.0/1.0 MB 27.5 MB/s eta 0:00:00[2022-07-07 14:04:37.432538]
Installing collected packages: protobuf
Attempting uninstall: protobuf
Found existing installation: protobuf 3.20.1
Uninstalling protobuf-3.20.1:
Successfully uninstalled protobuf-3.20.1
Successfully installed protobuf-3.20.1
WARNING: You are using pip version 22.0.3; however, version 22.1.2 is available.
You should consider upgrading via the ‘/home/appuser/venv/bin/python -m pip install --upgrade pip’ command.

────────────────────────────────────────────────────────────────────────────────────────

[14:04:39] :snake: Python dependencies were installed from /app/ticketmodel/requirements.txt using pip.
[14:04:39] :package: Processed dependencies!

[14:04:43] :arrows_counterclockwise: Updated app!
[14:12:08] :exclamation: The service has encountered an error while checking the health of the Streamlit app: Get “http://localhost:8501/healthz”: dial tcp 127.0.0.1:8501: connect: connection refused

Here was the end of the most recent logs. I removed all version numbers from the requirements.txt file and tried again before this error

Hmm, unfortunately i don’t see any error message :thinking:
I am running out of ideas, maybe delete the app and re-deploy?

I’ve already deleted the app and redeployed (a few times actually because I’ve been struggling with this for a month or two). Wouldn’t the very end where it states “the service has encountered an error” be the error message?

Below that it now also added the messages:
:exclamation: Streamlit server consistently failed status checks
:exclamation: Please fix the errors, push an update to the git repo, or reboot the app.

Once again, I really appreciate you taking the time to help me with this.

Thank you for making some changes on github. I merged these changes from your pull request and now get this error when trying to run the app

[20:30:18] 🐙 Pulling code changes from Github...
[20:30:29] ❗️ Updating the app files has failed: git pull, cmd: sudo -u appuser GIT_SSH_COMMAND='ssh -i /home/appuser/.ssh/id_github -o IdentitiesOnly=yes -o StrictHostKeyChecking=no -o "LogLevel ERROR"' git fetch origin && sudo -u appuser git reset --hard origin/main: error: exit status 128: error: unable to create file .streamlit/config.toml: Permission denied
fatal: Could not reset index file to revision 'origin/main'.

I tried it on streamlit cloud too, the deployment/installation runs without issues, the app starts, but then it crashes after loading the model. I don’t see any error message, maybe the app uses too much RAM :man_shrugging:
I tested the app locally with docker, there it worked.