I get python version error

ERROR: Could not find a version that satisfies the requirement python==3.7 (from versions: none)
ERROR: No matching distribution found for python==3.7
[manager] installer returned a non-zero exit code

Hi @mekala_madhankumar, welcome to the Streamlit community!

Can you post a link to the repo that you using that demonstrates this error?

Best,
Randy

Please check if this is the issue. I had a similar error and solved it when I changed the Python version in app settings.