Image not displaying when i deploy


I’m building a school project using streamlit but i have a problem with image.

My app is deployes on Community Cloud β†’
My repository β†’ GitHub - GuillaumeDupuy/PetroDash

My problem is i displayed image from url on map, when i run the code locally, is work fine but once deployed, some images are not displayed. I mean that images with a raw link work but those with an API call do not work.

The file of the map is in β†’ app/utils/

Expected behavior :

Actual behavior :

Python version : 3.10.11
Streamlit version : 1.28.0

I don’t understand why locally is work but deployed not

Hello, I tried lots of solutions but nothing really worked. I put back my basic code and it works. So, I know, it’s weird xD

Okay no to me time. The solution is not magic. I understood my mistake, I checked if in my brand column there was the character β€œ.” and I put that instead of β€œβ€.

Only do that, the app deployed did not do it / did not execute it and therefore broke all the image links.

So instead I directly change the brand which has a dot in its name

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.