Importerror: cannot open shared object file: no such file or directory opencv error

hey i am getting filenotfound error, my local host and my IDE is running very well, but when i deploy that app i am getting filenotfound error

I’ve got a same problem on my Mac, I’ve added requirements.txt as well as packages.txt but still having a same error message.
When I tried to do “pip install libjasper-dev” then it says

ERROR: Could not find a version that satisfies the requirement libjasper-dev (from versions: none)
ERROR: No matching distribution found for libjasper-dev

so does the case of “pip install libgl1-mesa-glx”

Here is the link for more detail info (traceback, requirements.txt, packages.txt)

It’s been struggling with this issue to deploy the app using Streamlit Sharing for 3 days now.

It looks like this might’ve been solved for you by @snehankekre in a different thread, but it’s important to note that system-level packages go in a packages.txt file, they don’t go in requirements.txt. requirements.txt is the Python standard for installing packages from pip, it doesn’t install system packages.


Yes, now I understand what you mean, Thanks a lot Randy.
It was a bit trouble for me to figure this issue out.
Hope other folks get some learning from my case as well.

Best regards