Installer returned a non-zero exit code / Error during processing dependencies

My app works fine locally, but on deployment it won’t boot as it fails to install requirements.

It says:

[10:52:40] ❗️ installer returned a non-zero exit code
[10:52:40] ❗️ Error during processing dependencies! Please fix the error and push an update, or try restarting the app.
[10:54:11] ❗️ Streamlit server consistently failed status checks
[10:54:11] ❗️ Please fix the errors, push an update to the git repo, or reboot the app.

Right after finished installing dependencies.

Browsing this forum, one potential cause could be out of memory but I haven’t added much and it worked earlier today, I believe.

The error message isn’t helpful — what should I do?

Welcome to the community!
This is too little information to give any advice.
We only see that an error occured during processing dependencies.
Please share a link to your public github repo.

Ah, adding /{project_name}/ fixed it!

Thanks for your comment, Franky1!