Issue with installation

Hello community,

I have been using Streamlit as well as streamlit cloud for a while but yesterday when I re-ran my code to check out a bug I found this error

Traceback (most recent call last):
File “C:\Users\IyerA3.conda\envs\data\lib\”, line 194, in _run_module_as_main
return run_code(code, main_globals, None,
File “C:\Users\IyerA3.conda\envs\data\lib\”, line 87, in run_code
exec(code, run_globals)
File "C:\Users\IyerA3.conda\envs\data\Scripts\streamlit.exe_main
.py", line 4, in
File "C:\Users\IyerA3.conda\envs\data\lib\site-packages\streamlit_init
.py", line 72, in
from streamlit.delta_generator import DeltaGenerator as DeltaGenerator
File “C:\Users\IyerA3.conda\envs\data\lib\site-packages\streamlit\”, line 19, in
from streamlit import cursor, caching
File “C:\Users\IyerA3.conda\envs\data\lib\site-packages\streamlit\”, line 18, in
from streamlit.script_run_context import get_script_run_ctx
File “C:\Users\IyerA3.conda\envs\data\lib\site-packages\streamlit\”, line 23, in
from streamlit.state.session_state import SessionState
File “C:\Users\IyerA3.conda\envs\data\lib\site-packages\streamlit\state\”, line 18, in
from streamlit.type_util import Key
File “C:\Users\IyerA3.conda\envs\data\lib\site-packages\streamlit\”, line 22, in
import pyarrow as pa
File "C:\Users\IyerA3.conda\envs\data\lib\site-packages\pyarrow_init
.py", line 63, in
import pyarrow.lib as _lib
ImportError: DLL load failed while importing lib: The specified procedure could not be found.


Having looked up the forum I uninstalled streamlit locally and re-installed using the option --no-cache-dir and now have the latest version (1.5.0) installed.

However I get the same error again.
I then tried a simple 2 line script to narrow the problem down

import streamlit as st


And yet the same issue occurs.

The pyarrow version I have on my machine is 3.0.0

Please can someone advice on how to overcome this issue?


Hey Ananth
Can you retry after upgrading pyarrow library once?

Steps to do that -
pip install --upgrade pyarrow


Hi Kanak,

I tried this just now and it fixed the issue.


1 Like