ModuleNotFound Error with docx2txt

Hi all!

I’m trying to build a chat bot which takes in docx files. When deploying the app locally, it works like a gem. However when deploying it onto streamlit’s community cloud, it returns an error that asks me to import the doc2txt module. Here is a snapshot of my requirments text file.

Appreciate the help!

Edit: Also appending the libraries I imported in the main app

Can you share the exact error that cloud shows, including the whole stack trace?

Hi,

Thanks for the quick response! Here you go:

Edit: this is clearer

Could you try removing the version on docx2txt in your requirements.txt file? It’s possible that the version of langchain you have is not compatible with docx2txt 0.8.

Could you share the repo you are using?

Hi,

Yes I’ve tried that as well and it doesn’t work still.

Here u go!

Hi @jemyap91

Have you tried rebooting the app, this would help to ensure that the restart would force the server to install all libraries in the requirements.txt file.

Hi dataprof,

This is embarrassing, but yes it works now! Thanks for the pro tip :wink:

1 Like

Hi @jemyap91

This happens for me all the time, a good old reset usually does the trick :slight_smile:

1 Like