ModuleNotFoundError in Plotly

Hi everyone,

I tried to deploy my code from Github to Streamlit Cloud but i have a problem

ModuleNotFoundError: No module named 'plotly'
2024-01-12 12:13:52.434 503 GET /script-health-check (10.12.154.245) 163.52ms
2024-01-12 12:13:57.285 Uncaught app exception
Traceback (most recent call last):
  File "/home/adminuser/venv/lib/python3.9/site-packages/streamlit/runtime/scriptrunner/script_runner.py", line 535, in _run_script
    exec(code, module.__dict__)
  File "/mount/src/jobtest/Atmind_Data_Test1.py", line 3, in <module>
    import plotly.express as px

Can you please have me fix this problem? I think it have problem with python because I use python 3.10 but in this problem use a python 3.9

You just need to install plotly.

You need a requirements.txt file in your github repo:

requirements.txt

pandas
streamlit
plotly