ModuleNotFoundError: No module named ‘sklearn’

I am trying to deploy my model but i keep getting this error ModuleNotFoundError: No module named ‘sklearn’, I have tried various ways but still the same.
Please help

Github: GitHub - ChibuikeOnuba/Diabetes-Prediction


Must it be named

requirements.txt ?
Cos I named mine req.text

Yes, library dependencies are looked for in the requirements.txt file for those that you want to pip install. packages.txt for those that you want the Ubuntu OS to install, environment.yml for conda, and more details at App dependencies - Streamlit Docs

It worked thanks
Another error just popped up lol
I’ll try to fix it and keep you posted

hi im getting the same error everything is perfect still it continues

here is my repo [GitHub - AMMS46/Laptop-Price-Prediction]

your requirements file should be called requirement.txt

No that’s wrong, the correct name must be requirements.txt

Hey @FrAmeS ,

Just a kind reminder that you put your working versions beside the package name.

Streamlit cloud tries it’s best to replicate your localhost machine when trying to deploy. Having the current versions ensures that the same features are available from the imported libraries.

You can use pip freeze or pip list to find the versions.

Hope this helps!

1 Like

thanks @Anirudh_Vangara
yes it does

Hi! I get the same error
My repo is

@Andrei23 you can try deleting the app in the cloud and host it again, it works for me

1 Like

It worked for me, thank you so much! I was already beginning to give up hope…

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.