ModuleNotFoundError: This app has encountered an error. from sklearn.ensemble import RandomForestRegressor

Hi everyone! My app has been working just fine all the year. However, today it suddenly stop working. This is the error message:

ModuleNotFoundError: This app has encountered an error. The original error message is redacted to prevent data leaks. Full error details have been recorded in the logs (if you’re on Streamlit Cloud, click on ‘Manage app’ in the lower right of your app).

File "/home/appuser/venv/lib/python3.9/site-packages/streamlit/runtime/scriptrunner/", line 564, in _run_script
    exec(code, module.__dict__)
File "/app/ds4app/", line 25, in <module>
    from sklearn.ensemble import RandomForestRegressor

My Github Link:

Thank you for your help :slight_smile:

Is this hosted in Streamlit Cloud? If so, have you rebooted the app? I believe I have read that sometimes with updates or changes in dependencies that things can get a little stuck so a clean reboot if a good first place to start.


I do see sklearn in your requirements file and maybe that you tried adding scikit-learn to see if it would help. I would trim it back to just sklearn before the reboot as I think sklearn is sufficient, but if it’s still not working after a full reboot, maybe check the versions (both for Streamlit and the dependencies). I see none are specified in the requirements file, but when you reboot and let it rebuild you can see what all it’s grabbing from the logs.

If this isn’t in Streamlit Cloud, can you provide further information about your environment? If you’ve updated any packages recently, have you tried a clean environment with a fresh install of the packages?

Hi mathcatsand!

It is Streamlit Cloud. I rebooted the app, but it shows the same error. Then I added scikit-learn to the requirements.txt and it worked! My app is back online

Thank you for the fast reply.

Awesome! (I think I’ll play around with a little app and see if I can see how Streamlit Cloud is handling the sklearn and scikit-learn duality for my own curiosity. :thinking:) Anyways, glad the reboot worked!

1 Like

And I just checked: sklearn is deprecated for pip, so scikit-learn is right for the requirements file. Makes sense. :slight_smile: